High Load on App Catalog Following Recent Update
Resolved
Aug 01 at 09:03am CEST
The App Catalog has now stabilized, and performance has returned to normal levels following the rollout of the new app version. All endpoints should receive the updated version within the next 24 hours if they have not already.
We will continue to monitor the system closely, but no further impact to users is expected.
Affected services
Updated
Jul 31 at 01:02pm CEST
We have released a new version of the app that rolls back the previous update. This version is currently being rolled out and will be automatically available to all endpoints within the next 24 hours. Our team continues to monitor the system to ensure performance stability.
Affected services
Created
Jul 31 at 10:34am CEST
We are currently experiencing a significant increase in load on the App Catalog following the recent release of the latest app update. This elevated traffic is causing performance degradation for some users.
Our engineering team is actively investigating the root cause of the issue. In the meantime, we are preparing and releasing a rollback update to revert the recent code changes to stabilize the system. Further updates will be provided as the situation develops.
Affected services